RFR: 2312: Do not require re-review for a simple merge [v5]

Pavel Rappo prappo at openjdk.org
Wed Jul 10 13:35:54 UTC 2024


> If a repository is configured to ignore stale reviews, every commit to a PR made against that repo means that the PR needs to be re-reviewed. Re-reviewing is costly, and not all commits are worth that cost.
> 
> One example of such a commit is a simple merge. During a PR's lifetime, the PR's target branch (typically, repo's `master`) might be merged into the PR multiple times. Usually, such merges are trivial and would effectively be performed by Skara automatically if the PR didn't have them in the first place [^*]. For such commits, it makes sense to not require review.
> 
> This is my first contribution to Skara domain logic, which I've just started learning about. Also, while I tried to code this change according to Skara customs and idioms, I might have missed something. I guess what I'm saying is **take extra care** reviewing this PR. Thanks.
> 
> 
> [^*]: This is the main assumption of this PR. Any simple merges present in a PR change the end result of that PR insignificantly, if at all.

Pavel Rappo has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains six additional commits since the last revision:

 - Rename properties as suggested
   
   IMPORTANT
   ---------
   
   The ignoreStale JSON property is now called useStaleReviews. The
   semantics of useStaleReviews is the opposite (negated) that of
   ignoreStale.
   
   That means that all repos that are configured with ignoreStale set to
   true should instead be configured with useStaleReviews set to false or
   useStaleReviews absent. And the repositories whose configuration doesn't
   contain ignoreStale or whose ignoreStale is set to false should instead
   be configured with useStaleReviews set to true.
   
   In any case, if present, ignoreStale should be removed from a repo
   configuration as that property is now unrecognised.
 - Merge branch 'master' into 2312
 - Respond to feedback
 - Respond to feedback
   
   Pulls up new methods from GitRepository.
 - Respond to feedback
 - Initial commit

-------------

Changes:
  - all: https://git.openjdk.org/skara/pull/1672/files
  - new: https://git.openjdk.org/skara/pull/1672/files/0c295858..18ecf690

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=skara&pr=1672&range=04
 - incr: https://webrevs.openjdk.org/?repo=skara&pr=1672&range=03-04

  Stats: 391 lines in 70 files changed: 143 ins; 60 del; 188 mod
  Patch: https://git.openjdk.org/skara/pull/1672.diff
  Fetch: git fetch https://git.openjdk.org/skara.git pull/1672/head:pull/1672

PR: https://git.openjdk.org/skara/pull/1672


More information about the skara-dev mailing list