<Swing Dev> review request for 6899434: Add affine transform support to JLayer
Artem Ananiev
Artem.Ananiev at Sun.COM
Fri Feb 5 14:36:54 UTC 2010
Hi, Piet,
I haven't looked through the entire webrev and inspected mostly an AWT
part of the fix. A question is whether it's possible to get rid of the
new "conversionShift" field in Container, to make transformations
support really stateless?
Another option to consider is to make some of the existing methods (e.g.
getMouseEventTargetImpl()) public instead of introducing new ones.
Thanks,
Artem
On 1/28/2010 8:21 PM, Piet Blok wrote:
> Hello all,
>
> review request for 6899434: Add affine transform support to JLayer
>
> The webrev: http://www.pbjar.org/OpenJDK/6899434/webrev/
>
> The patch covers all the requested functionality. It is concentrated in
> JLayer class, keeping in mind to affect the library as little as possible.
>
> 1) A setter and getter for the transform in JLayer
>
> 2) The paint method in JLayer has been adapted to use the transform
>
> 3) RepaintManager has been adapted to propagate repaint requests from
> the view or any of its children to the top level JLayer and have the
> dirty region transformed.
>
> 4) java.awt.Container and java.awt.LightweightDispatcher (both in the
> same source) have been adapted to redispatch MouseEvents to the intended
> target component. The lookup for the component that provides a custon
> cursor has also been adapted.
>
> 5) To enable Container to do necessary reculculations, a protected
> method has been introduced that will be overridden by JLayer:
> protected Point getConvertedPoint(Point point).
> (If someone can suggest a better name for this method I'm glad to hear)
>
> 6) A package private method in SwingUtilities has been added that helps
> JPopupMenu and ToolTipManager to find the correct popup location.
> JPopupMenu and ToolTipManager have been changed to use this new method
> in their calculations.
>
> 7) Two jtreg tests have been added.
>
> Looking forward for comments.
>
> Thanks,
> Piet
>
>
>
More information about the swing-dev
mailing list