<Swing Dev> review request for 6899434: Add affine transform support to JLayer
Piet Blok
pbhome at ziggo.nl
Thu Jan 28 17:21:16 UTC 2010
Hello all,
review request for 6899434: Add affine transform support to JLayer
The webrev: http://www.pbjar.org/OpenJDK/6899434/webrev/
The patch covers all the requested functionality. It is concentrated in
JLayer class, keeping in mind to affect the library as little as possible.
1) A setter and getter for the transform in JLayer
2) The paint method in JLayer has been adapted to use the transform
3) RepaintManager has been adapted to propagate repaint requests from the
view or any of its children to the top level JLayer and have the dirty
region transformed.
4) java.awt.Container and java.awt.LightweightDispatcher (both in the same
source) have been adapted to redispatch MouseEvents to the intended target
component. The lookup for the component that provides a custon cursor has
also been adapted.
5) To enable Container to do necessary reculculations, a protected method
has been introduced that will be overridden by JLayer:
protected Point getConvertedPoint(Point point).
(If someone can suggest a better name for this method I'm glad to hear)
6) A package private method in SwingUtilities has been added that helps
JPopupMenu and ToolTipManager to find the correct popup location. JPopupMenu
and ToolTipManager have been changed to use this new method in their
calculations.
7) Two jtreg tests have been added.
Looking forward for comments.
Thanks,
Piet
More information about the swing-dev
mailing list