<Swing Dev> [8] Review request for 8024395: Improve fix for line break calculations

Alexander Scherbatiy alexandr.scherbatiy at oracle.com
Mon Sep 9 12:59:18 UTC 2013


On 9/6/2013 6:38 PM, dmitry markov wrote:
> Hello,
>
> Could you review the fix:
>   bug: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8024395
>   webrev: http://cr.openjdk.java.net/~dmarkov/8024395/jdk8/webrev.00/
>
> The fix reverts the changes added for JDK-8014863 and override 
> forwardUpdate() method for LogicalView class located at FlowView. In 
> other words View.forwardUpdate() will go back to its original behavior 
> and LogicalView.forwardUpdate() will send update event to all views 
> followed by the changed place. This event will cause view to drop the 
> cache and re-calculate its break points.

     - The FlowView class extends BoxView and the BoxView calls 
super.forwardUpdate(ec, e, a, f). Should the FlowView class also have 
super call in the forwardUpdate method?
     - It is usually not good to have duplicated codes in some methods. 
Is it possible to unite the same parts of code of forwardUpdatemethod 
from View and FlowView class to a method with package access?
     - It should be possible to use {@inheritDoc} tag for the method doc.

     Thanks,
     Alexandr.

>
> Thanks,
> Dmitry




More information about the swing-dev mailing list