<Swing Dev> [11] RFR JDK-8202199 : Provide public, unsupported API for FX Swing interop
Kevin Rushforth
kevin.rushforth at oracle.com
Tue May 8 15:19:45 UTC 2018
Exactly. The current naming was recommended by the jigsaw team, and I
fully agree.
-- Kevin
On 5/8/2018 12:53 AM, Prasanta Sadhukhan wrote:
> We have discussed this internally and we believe that
> "unsupportedness" is the critical property here so it justifies
> grouping them in the same "unsupported" namespace rather than desktop
> namespace.
>
> Regards
> Prasanta
> On 5/8/2018 12:56 PM, Ali Ebrahimi wrote:
>> Hi,
>> What about " jdk.desktop.unsupported" for new module name?
>>
>> On Tue, May 8, 2018 at 10:21 AM, Prasanta Sadhukhan
>> <prasanta.sadhukhan at oracle.com
>> <mailto:prasanta.sadhukhan at oracle.com>> wrote:
>>
>> Modified webrev to rename to InteropProviderImpl
>>
>> http://cr.openjdk.java.net/~psadhukhan/fxswing.10/
>> <http://cr.openjdk.java.net/%7Epsadhukhan/fxswing.10/>
>>
>> Regards
>> Prasanta
>>
>> On 5/7/2018 8:35 PM, Kevin Rushforth wrote:
>>
>> That name seems good to me.
>>
>> -- Kevin
>>
>>
>> On 5/7/2018 8:01 AM, Prasanta Sadhukhan wrote:
>>
>> Would InteropProviderImpl sound good?
>>
>> Regards
>> Prasanta
>> On 5/7/2018 8:27 PM, Alan Bateman wrote:
>>
>>
>>
>> On 07/05/2018 10:26, Prasanta Sadhukhan wrote:
>>
>> :
>>
>> Modified webrev to use InteropProvider
>> http://cr.openjdk.java.net/~psadhukhan/fxswing.9/
>> <http://cr.openjdk.java.net/%7Epsadhukhan/fxswing.9/>
>>
>> This looks okay although for consistent then
>> InteropImpl could be renamed too.
>>
>> -Alan
>>
>>
>>
>>
>>
>>
>>
>> --
>>
>> Best Regards,
>> Ali Ebrahimi
>
More information about the swing-dev
mailing list