[lworld] RFR: 8231500: [lworld] Merge the experimental bytecode API [v2]

David Simms dsimms at openjdk.java.net
Wed Dec 2 10:28:22 UTC 2020


On Tue, 1 Dec 2020 18:16:59 GMT, Mandy Chung <mchung at openjdk.org> wrote:

>> David Simms has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Review comments applied
>
> test/jdk/java/lang/invoke/common/test/java/lang/invoke/lib/InstructionHelper.java line 271:
> 
>> 269: 
>> 270:             @Override
>> 271:             public boolean isValue(String desc) {
> 
> I think we should rename `isValue` to `isInlineClass` and also other new `xxxValue` methods

Comments applied

> test/jdk/java/lang/invoke/common/test/java/lang/invoke/lib/InstructionHelper.java line 171:
> 
>> 169:     }
>> 170: 
>> 171:     public static MethodHandle loadCode(MethodHandles.Lookup lookup, String className, String methodName, MethodType type, Consumer<? super MethodHandleCodeBuilder<?>> builder) {
> 
> Are these two `loadCode` methods taking a builder `Consumer` used by the tests?
> 
> If so, the following classes and methods can be made private to hide them as internals.

Comments applied

> test/jdk/lib/testlibrary/bytecode/jdk/experimental/bytecode/BasicTypeHelper.java line 49:
> 
>> 47: 
>> 48:     @Override
>> 49:     public boolean isValue(String t) {
> 
> s/isValue/isInlineClass/

Comments applied

> test/jdk/lib/testlibrary/bytecode/jdk/experimental/bytecode/BasicTypeHelper.java line 59:
> 
>> 57: 
>> 58:     @Override
>> 59:     public String valueType(String s) {
> 
> s/valueType/inlineType/

Comments applied

> test/jdk/lib/testlibrary/bytecode/jdk/experimental/bytecode/BytePoolHelper.java line 341:
> 
>> 339: 
>> 340:     @Override
>> 341:     public int putValueClass(S symbol) {
> 
> s/putValueClass/putInlineClass/

Comments applied

-------------

PR: https://git.openjdk.java.net/valhalla/pull/279


More information about the valhalla-dev mailing list