[lworld] RFR: 8260606: Update Valhalla core-libs naming for methods related to primitive classes
Mandy Chung
mchung at openjdk.java.net
Wed Feb 3 19:23:00 UTC 2021
On Tue, 2 Feb 2021 20:55:07 GMT, Roger Riggs <rriggs at openjdk.org> wrote:
> Update terminology used to refer to primitive classes (from inline classes).
> Drop the descriptions using "projection" and use "conversion" as needed.
> Updated dependencies on Class.isPrimitiveClass().
>
> [Updating test names will be a separate task.]
src/java.base/share/classes/java/lang/Class.java line 666:
> 664: * is returned.
> 665: */
> 666: private Class<?>[] newPrimitiveTypeArray() {
perhaps rename to `newTypeArrayForPrimitiveClass`
src/java.base/share/classes/java/lang/invoke/ValueBootstrapMethods.java line 555:
> 553:
> 554: /**
> 555: * Invoke the bootstrap methods hashCode for the given primitive classobject.
a space is missing in `classobject`
src/java.base/share/classes/java/lang/invoke/ValueBootstrapMethods.java line 557:
> 555: * Invoke the bootstrap methods hashCode for the given primitive classobject.
> 556: * @param o the instance to hash.
> 557: * @return the hash code of the given primitive classobject.
space is missing in the word `classobject`
src/java.base/share/classes/java/lang/invoke/ValueBootstrapMethods.java line 584:
> 582: * Invoke the bootstrap methods hashCode for the given primitive classobject.
> 583: * @param o the instance to hash.
> 584: * @return the string representation of the given primitive classobject.
same typo `classobject`
-------------
PR: https://git.openjdk.java.net/valhalla/pull/318
More information about the valhalla-dev
mailing list