[lworld] RFR: 8263024: Convert Valhalla tests using the old framework to the new framework [v2]

Ekaterina Pavlova epavlova at openjdk.java.net
Wed Jul 14 00:51:34 UTC 2021


On Tue, 13 Jul 2021 07:32:30 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:

>> Ekaterina Pavlova has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains two commits:
>> 
>>  - Merge lworld
>>  - Converted to new IR framework
>
> test/hotspot/jtreg/compiler/valhalla/inlinetypes/TestIntrinsics.java line 90:
> 
>> 88:     // Verify that Class::isAssignableFrom checks with statically known classes are folded
>> 89:     @Test
>> 90:     @IR(failOn = {LOADK})
> 
> Can be simplified to `failOn  = LOADK`.

I specially kept {} so it will be more straightforward to add more nodes if needed. But I can remove {} if you prefer simplified version.

> test/hotspot/jtreg/compiler/valhalla/inlinetypes/TestIntrinsics.java line 126:
> 
>> 124:     // Verify that Class::getSuperclass checks with statically known classes are folded
>> 125:     @Test
>> 126:     @IR(failOn = {LOADK})
> 
> Can be simplified to `failOn = LOADK`.

I actually specially kept {} so it will be more straightforward to add more nodes if needed. But I can remove {} if you prefer simplified version.

> test/hotspot/jtreg/compiler/valhalla/inlinetypes/TestIntrinsics.java line 384:
> 
>> 382: 
>> 383:     @Test
>> 384:     @IR(failOn = {CALL_Unsafe})
> 
> Can be simplified to `failOn = CALL_Unsafe`. There are some more of them below which could be simplified as well.

see previous comment

> test/hotspot/jtreg/compiler/valhalla/inlinetypes/TestLWorld.java line 3478:
> 
>> 3476:     // acmp doesn't need substitutability test when one input null
>> 3477:     @Test
>> 3478:     @IR(failOn = {SUBSTITUTABILITY_TEST})
> 
> Can be simplified to `failOn = SUBSTITUTABILITY_TEST`.

see previous comment

-------------

PR: https://git.openjdk.java.net/valhalla/pull/457



More information about the valhalla-dev mailing list