[lworld+vector] RFR: 8307715: Integrate VectorMask with value/primitive classes [v2]
Xiaohong Gong
xgong at openjdk.org
Thu May 18 08:35:14 UTC 2023
On Thu, 18 May 2023 06:32:32 GMT, Jatin Bhateja <jbhateja at openjdk.org> wrote:
>> Xiaohong Gong has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Fix issue when the boxed type is not equal to the intrinsic return type
>
> src/hotspot/share/opto/vector.cpp line 248:
>
>> 246: // Multi-field based vectors are InlineTypeNodes and are already
>> 247: // scalarized by process_inline_types.
>> 248: if (is_vector(iklass) || is_vector_mask(iklass)) {
>
> We can directly use _!is_vector_shuffle(iklass)_
These code will be removed after shuffle is supported. I will push the patch soon with more clean-ups. Thanks for your review!
> src/hotspot/share/opto/vector.cpp line 495:
>
>> 493: // Since intrinsification is skipped upfront for mask/shuffle related operations
>> 494: // this is anyways a dead code currently.
>> 495: void PhaseVector::expand_vunbox_node_shuffle(VectorUnboxNode* vec_unbox) {
>
> You can also remove mask related functionality from this routines, since you have already moved it to box creation method.
Same as before. These will be cleaned-up soon.
> src/jdk.incubator.vector/share/classes/jdk/incubator/vector/Double64Vector.java line 642:
>
>> 640: return VectorSupport.binaryOp(VECTOR_OP_AND, Double64Mask.class, null,
>> 641: long.class, VLENGTH, this, m, null,
>> 642: (m1, m2, vm) -> (Double64Mask) m1.bOp(m2, (i, a, b) -> a & b));
>
> There is difference in naming convention of fallback routine b/w masks (bOp) and vectors (bOpMF), we should have a one consistent convention.
Good catch! I will fix this later. Thanks!
-------------
PR Review Comment: https://git.openjdk.org/valhalla/pull/845#discussion_r1197551948
PR Review Comment: https://git.openjdk.org/valhalla/pull/845#discussion_r1197552997
PR Review Comment: https://git.openjdk.org/valhalla/pull/845#discussion_r1197553791
More information about the valhalla-dev
mailing list