[OpenJDK 2D-Dev] RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

Dmitriy Dumanskiy github.com+1536494+doom369 at openjdk.java.net
Thu Sep 10 08:52:21 UTC 2020

**isEmpty** is faster + has less byte code + easier to read. Benchmarks could be found


Commit messages:
 - Merge branch 'master' of https://github.com/doom369/jdk into reaplce_equals_with_is_empty
 - revert change in classes that maintain jdk 1.4 compatibility
 - Improvement: replace all occurrences of the .equals("") usages with .isEmpty()

Changes: https://git.openjdk.java.net/jdk/pull/29/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=29&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8252999
  Stats: 234 lines in 150 files changed: 0 ins; 0 del; 234 mod
  Patch: https://git.openjdk.java.net/jdk/pull/29.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/29/head:pull/29

PR: https://git.openjdk.java.net/jdk/pull/29

More information about the 2d-dev mailing list