<AWT Dev> [8] Review request for: 7172722: Latest jdk7u from OSX broke universal build

Anthony Petrov anthony.petrov at oracle.com
Thu May 31 14:55:28 PDT 2012

All: please review the fix (a link to the webrev is below)

Hi Henri,

On 5/31/2012 11:41 PM, Henri Gomez wrote:
> Not subscribed to this mailing list.

This is not a problem at all! You may just hit the Reply All button on 
the original review request email that I've sent (I've included your 
address in the To: section so you should have received a copy). The 
message will simply go through a moderator of the mailing list, and once 
approved will hit the mailing list as usual.

Anyway, I'm CC'ing the original aliases right now so that this 
conversation could contribute to the code review.

> +    NSWindow *nsWindow;
> BTW, your patch should do the work (it was my first attempt before

Thanks for verifying that.

> friends told me that _nsWindow is a convention to follow in ObjC/Cocoa
> land.

I realize that this may be a convention in the ObjC world. However, in 
JDK we tend to establish a pattern and then follow it everywhere to 
simplify maintenance of the code. Since other properties are defined 
this way, I decided to do the same with this one too.

best regards,

> 2012/5/31 Anthony Petrov <anthony.petrov at oracle.com>:
>> Hi Henri,
>> Have you had a chance to give this patch a try? Please reply to the mailing
>> list with your testing results.
>> --
>> best regards,
>> Anthony
>> -------- Original Message --------
>> Subject: <AWT Dev> [8] Review request for: 7172722: Latest jdk7u from OSX
>> broke universal build
>> Date: Wed, 30 May 2012 16:13:18 +0400
>> From: Anthony Petrov <anthony.petrov at oracle.com>
>> To: macosx-port-dev <macosx-port-dev at openjdk.java.net>,
>> "awt-dev at openjdk.java.net" <awt-dev at openjdk.java.net>,        Henri Gomez
>> <henri.gomez at gmail.com>
>> Hello,
>> Please review a fix for http://bugs.sun.com/view_bug.do?bug_id=7172722 at:
>> http://cr.openjdk.java.net/~anthony/8-33-MacUniversalBuild-7172722.0/
>> I've simplified the fix comparing to original Henri's proposal [1] to
>> follow the same pattern as we use with other properties: we simply give
>>  the corresponding class fields the same names as to the properties
>> themselves.
>> Henri: please verify if the new patch works for you.
>> [1] http://mail.openjdk.java.net/pipermail/jdk7u-dev/2012-May/003191.html

More information about the awt-dev mailing list