<AWT Dev> [9] Review request for JDK-8151787 Unify the HiDPI splash screen image naming convention

Alexander Scherbatiy alexandr.scherbatiy at oracle.com
Fri Apr 29 11:47:54 UTC 2016


The fix looks good to me.

Thanks,
Alexandr.

On 29/04/16 13:49, Rajeev Chamyal wrote:
>
> Hello Alexandr,
>
> Please review the updated fix.
>
> http://cr.openjdk.java.net/~rchamyal/8151787/webrev.02/ 
> <http://cr.openjdk.java.net/%7Erchamyal/8151787/webrev.02/>
>
> - Will the java-scale2x image be chosen if fileName2x is nil on the 
> line 163?
>
> fileName2x cannot be nil SplashGetScaledImageName is called only if a 
> not null value is passed in filename and
>
> other parameters to new method findScaledImageName are constants.
>
> - Could you add the use case where both @2x and java-scale2x are 
> provided and @2x is chosen in the test?
>
> I have updated the test as suggested.
>
> Regards,
>
> Rajeev Chamyal
>
> *From:*Alexandr Scherbatiy
> *Sent:* 28 April 2016 00:20
> *To:* Rajeev Chamyal; awt-dev at openjdk.java.net; Sergey Bylokhov
> *Subject:* Re: <AWT Dev> [9] Review request for JDK-8151787 Unify the 
> HiDPI splash screen image naming convention
>
> On 4/27/2016 7:40 PM, Rajeev Chamyal wrote:
>
>     Hello Alexandr,
>
>     Please review the updated fix.
>
>     http://cr.openjdk.java.net/~rchamyal/8151787/webrev.01/
>     <http://cr.openjdk.java.net/%7Erchamyal/8151787/webrev.01/>
>
>
>  162         fileName2x = findScaledImageName(fileName, dotIndex, @"@2x");
>  163         if(fileName2x != nil && ![[NSFileManager defaultManager]
>  164                                   fileExistsAtPath: fileName2x]) {
>  165             fileName2x = findScaledImageName(fileName, dotIndex, 
> @".java-scale2x");
>  166         }
>
> - Will the java-scale2x image be chosen if fileName2x is nil on the 
> line 163?
> - Could you add the use case where both @2x and java-scale2x are 
> provided and @2x is chosen in the test?
>
> Thanks,
> Alexandr.
>
>
>     Regards,
>
>     Rajeev Chamyal
>
>     *From:*Alexandr Scherbatiy
>     *Sent:* 26 April 2016 14:22
>     *To:* Rajeev Chamyal; awt-dev at openjdk.java.net
>     <mailto:awt-dev at openjdk.java.net>; Sergey Bylokhov
>     *Subject:* Re: <AWT Dev> [9] Review request for JDK-8151787 Unify
>     the HiDPI splash screen image naming convention
>
>     On 4/26/2016 11:13 AM, Rajeev Chamyal wrote:
>
>
>         Hello All,
>
>         Could you please review the following fix.
>
>         Bug : https://bugs.openjdk.java.net/browse/JDK-8151787
>
>         Webrev :
>         http://cr.openjdk.java.net/~rchamyal/8151787/webrev.00/
>         <http://cr.openjdk.java.net/%7Erchamyal/8151787/webrev.00/>
>
>         This is a small enhancement to support similar HiDPI splash
>         screen image name convention on all platforms.
>
>         Currently we have different naming convention for scaled
>         images on different platforms.
>
>         Image name : image.ext
>
>         Scaled image names:
>
>         Windows : image.scale-dpiValue.ext
>         Linux : image.java-scale2x.ext
>         MAC image at 2x.ext <mailto:image at 2x.ext>
>
>         After the fix naming convention on Mac and Linux would be :
>
>         Image name : image.ext
>
>         Scaled image name : image.java-scale2x./ext/
>
>         Both name conventions @2x and java-scale2x should be supported
>     on Mac OS X.
>         The more specific one @2x should be checked in the first place
>     and the java-scale2x in the second.
>
>        Thanks,
>        Alexandr./
>     //
>
>
>     /
>
>         Naming convention on windows :
>
>         Image name : image.ext
>
>         Scaled image name : image.java-scale<dpi value>./ext/
>
>         Regards,
>
>         Rajeev Chamyal
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/awt-dev/attachments/20160429/929e1961/attachment.html>


More information about the awt-dev mailing list