<AWT Dev> RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

Dmitriy Dumanskiy github.com+1536494+doom369 at openjdk.java.net
Thu Sep 10 08:52:25 UTC 2020

On Sun, 6 Sep 2020 18:08:15 GMT, thatsIch <github.com+2210496+thatsIch at openjdk.org> wrote:

>> **isEmpty** is faster + has less byte code + easier to read. Benchmarks could be found
>>   [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416).
> @doom369 jcheck requires an associated issue

@mrserb hello. Thanks for the review. Any further actions required from me?


PR: https://git.openjdk.java.net/jdk/pull/29

More information about the awt-dev mailing list