<AWT Dev> Withdrawn: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

Dmitriy Dumanskiy github.com+1536494+doom369 at openjdk.java.net
Fri Sep 11 07:18:17 UTC 2020

On Sun, 6 Sep 2020 13:57:19 GMT, Dmitriy Dumanskiy <github.com+1536494+doom369 at openjdk.org> wrote:

> **isEmpty** is faster + has less byte code + easier to read. Benchmarks could be found
>   [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416).

This pull request has been closed without being integrated.


PR: https://git.openjdk.java.net/jdk/pull/29

More information about the awt-dev mailing list