<AWT Dev> RFR: 8260931: Implement JEP 382: New macOS Rendering Pipeline [v3]
kcr at openjdk.java.net
Mon Feb 8 14:25:50 UTC 2021
On Mon, 8 Feb 2021 13:40:22 GMT, Ajit Ghaisas <aghaisas at openjdk.org> wrote:
>> make/modules/java.desktop/lib/Awt2dLibraries.gmk line 894:
>>> 892: SHADERS_SUPPORT_DIR := $(SUPPORT_OUTPUTDIR)/native/java.desktop/libosxui
>>> 893: SHADERS_AIR := $(SHADERS_SUPPORT_DIR)/shaders.air
>>> 894: SHADERS_LIB := $(INSTALL_LIBRARIES_HERE)/shaders.metallib
>> Q: Should 2d (or awt) be in the name of this file, or is a generic name OK?
> I think, a generic name is OK as the path of shader file already has both awt (libawt_lwawt) and java2d in it.
In the source tree, yes, but not in the jdk image where it ends up in `$JAVA_HOME/lib/shaders.metallib`. I don't have a problem with this, as long as it is a deliberate decision.
More information about the awt-dev