<AWT Dev> RFR: 8260931: Implement JEP 382: New macOS Rendering Pipeline [v3]
aghaisas at openjdk.java.net
Tue Feb 9 07:37:41 UTC 2021
On Mon, 8 Feb 2021 14:22:27 GMT, Kevin Rushforth <kcr at openjdk.org> wrote:
>> I think, a generic name is OK as the path of shader file already has both awt (libawt_lwawt) and java2d in it.
> In the source tree, yes, but not in the jdk image where it ends up in `$JAVA_HOME/lib/shaders.metallib`. I don't have a problem with this, as long as it is a deliberate decision.
OK. I get your point. Keeping the name unchanged for now as there won't be another .metallib in JDK. The name can be changed in the future if need arises.
More information about the awt-dev