<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
<body bgcolor="#FFFFFF" text="#000000">
Thank you for your feedback!<br>
It seems correct and appropriate to me, so I'll incorporate your
suggestions into the JEP.
<meta http-equiv="content-type" content="text/html; charset=utf-8">
<pre class="moz-signature" cols="72">Thanks,
<div class="moz-cite-prefix">On 09/27/2015 09:42 AM, Anthony
<blockquote cite="mid:56078FDD.email@example.com" type="cite">Hi
I have a few questions/comments about the proposed API:
- why not add a class java.awt.Taskbar instead, containing all the
functionality of the "setDock..." methods? In my opinion, this
would be a more logical place for this. Plus it would have the
nice side-effect that "SystemTray" and "Taskbar" would be adjacent
to each other in the Javadoc listing, aiding even more in
- I'm not fond of the naming of the listeners. In my opinion,
AppEventListener should be renamed to SystemEventListener, and
listeners for "external" events (such as
ScreenSleep/SystemSleep/UserSession) should not be prefixed with
App. So for example you would have UserSessionListener which
extends SystemEventListener instead of the current
AppUserSessionListener which extends AppEventListener.
- on a final note: the correct spelling is "reopen", so
AppReOpenedListener should be renamed to AppReopenedListener.
Thanks in advance for any feedback.