RFR(T) : 8219132 : switch to jtreg4.2-b14

Igor Ignatyev igor.ignatyev at oracle.com
Wed Feb 20 01:06:59 UTC 2019


Hi Erik,

thanks for your review. 

we can't just bump the required version as it can introduce changes in tests' behavior. requiredVersion >= 4.2 b14 will enable allowSmartActionArgs[1], this will affect all the tests which have ${<X>} in their @run directives, for example it will affect many vmTestbase tests which use PropertyResolvingWrapper. therefore, I suggest we bump requiredVersion after we clean up such tests and have filed 8219140[2] to deal w/ vmTestbase tests. I'll check if there are other tests which will be affected and will file RFE(s) to cover them as well.

[1] https://bugs.openjdk.java.net/browse/CODETOOLS-7902352 <https://bugs.openjdk.java.net/browse/CODETOOLS-7902352>
[2] https://bugs.openjdk.java.net/browse/JDK-8219140 <https://bugs.openjdk.java.net/browse/JDK-8219140>

Thanks,
-- Igor

> On Feb 19, 2019, at 5:01 PM, Erik Joelsson <erik.joelsson at oracle.com> wrote:
> 
> Looks good.
> 
> Do we need to also bump the required version in the TEST.ROOT files?
> 
> /Erik
> 
> On 2019-02-19 16:34, Igor Ignatyev wrote:
>> http://cr.openjdk.java.net/~iignatyev//8219132/webrev.00/index.html
>>> 1 line changed: 0 ins; 0 del; 1 mod;
>> Hi all,
>> 
>> could you please review this one-liner which switch jtreg version to jtreg4.2-b14?
>> 
>> webrev: http://cr.openjdk.java.net/~iignatyev//8219132/webrev.00/index.html
>> JBS:  https://bugs.openjdk.java.net/browse/JDK-8219132
>> testing: tier[1-5], client tests and jcstress test group testing showed no new failures; spot checking of .jtr files also didn't find any anomalies
>> 
>> Thanks,
>> -- Igor



More information about the build-dev mailing list