Review request for 8021368: Launch of Java Web Start app fails with ClassCircularityError exception

Mandy Chung mandy.chung at
Fri Dec 13 16:20:09 UTC 2013


Thanks for the review.

On 12/13/2013 7:07 AM, Alan Bateman wrote:
> I looked at changes and the approach seems okay to me (at least I 
> can't of other ways to check for the override without also tickling 
> the issue. I think you are right that a special entry point for this 
> is excessive given that the result can be cached.
> A minor point on the SecurityManagerHelper constructor, shouldn't it be:
> boolean overridden = false;
> if (smgr.getClass() != SecurityManager.class) {
>     try { overridden = ... }
> }

yes that's better.  While SecurityManagerHelper should only be 
constructed when smgr is a subclass, I'll make the change.

> A minor comment on naming where "cache" seems a bit general given that 
> Class has several caches (I know useCaches is general too). Also I see 
> the new code is using "smgr" whereas everywhere every seems to be 
> using "sm", "security" or other.

Agree the name is too general.  Will rename it.


More information about the core-libs-dev mailing list