RFR 8012647: Add Arrays.parallelPrefix (prefix sum, scan, cumulative sum)

Doug Lea dl at cs.oswego.edu
Thu Jun 13 11:30:15 UTC 2013

> On 13/06/2013 10:30, Chris Hegarty wrote:
>> On 06/12/2013 05:07 PM, Alan Bateman wrote:
>>> On 12/06/2013 15:50, Chris Hegarty wrote:
>>>> ...
>>> Is the name final? Just curious if other names such as parallelScan
>>> have
>>> been considered (and discarded).
>> I think we should be open to discussing the name, but I will have to
>> defer to Doug as to whether other names were considered/discarded.

Well, I originally called it "cumulate" and still like it best,
but others on expert group suggested parallelPrefix as less
likely to be confused with other methods they may be looking
for. So at this point I think we should stick with it.


More information about the core-libs-dev mailing list