RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull
mike.duigou at oracle.com
Tue Jun 25 18:15:37 UTC 2013
I am sympathetic to this naming issue (actually "indifferent" is more accurate) but it will have to wait until I return from vacation. I have tagged this thread and will follow up when I am back in the office. Please be patient, it will be addressed.
On Jun 20 2013, at 07:10 , Remi Forax wrote:
> Yes, a fine idea.
> On 06/20/2013 11:44 AM, Stephen Colebourne wrote:
>> Like others, I would prefer isNotNull() to notNull(). Mainly for
>> consistency, but also for dicoverability is IDE autocomplete (as the
>> methods would then be next to one another)
>> On 30 April 2013 23:45, Mike Duigou <mike.duigou at oracle.com> wrote:
>>> Hello all;
>>> Another changeset coming from the lambda libraries effort. This one is two small additions to the Objects class. The introduced methods are not really intended to be used directly, comparison operators work better in imperative logic, but the methods will be very useful as Predicates.
More information about the core-libs-dev