RFR [9] 8132468: docs: replace <tt> tags (obsolete in html5) for java.io, java.lang, java.math

Alexander Stepanov alexander.v.stepanov at oracle.com
Mon Aug 3 15:07:02 UTC 2015


Please see the updated webrev:
http://cr.openjdk.java.net/~avstepan/8132468/webrev.01/

removed wrapping <code></code> around the links (mostly 
PrintStream.java, PrintWriter.java, File.java), plus other changes in 
File.java

Thanks,
Alexander

On 8/3/2015 3:40 PM, Alexander Stepanov wrote:
> Hello Daniel,
>
> Thank you for the notes;
>
> > The <code></code> is not needed around {@link } - as that should be 
> the default formatting for {@link }
> Sorry, didn't know; I have to fix that.
>
> > Would that be easier to read as:
> Yes, probably that's better. Some old-style <code></code> tags were 
> saved just because of some extra code formatting (like italic letters, 
> <strong> or <sup> tags etc.) inside of them (which should be displayed 
> literally in case of {@code })
>
> > if the goal is to replace <code></code> and <tt></tt> everywhere
> Sorry, I didn't replace *all* of <code></code>, just some of them. The 
> main intention was to replace just <tt></tt> (as the tag is deprecated 
> for HTML5, in contrast to the <code>). So the touched packages (and 
> even files) still have a lot of <code> tags.
>
> Thanks,
> Alexander
>
> On 8/3/2015 3:17 PM, Daniel Fuchs wrote:
>> On 03/08/15 11:31, Alexander Stepanov wrote:
>>> Hello,
>>>
>>> Could you please review the following fix:
>>> http://cr.openjdk.java.net/~avstepan/8132468/webrev.00/
>>> for
>>> https://bugs.openjdk.java.net/browse/JDK-8132468
>>>
>>> Just some cleanup for docs (replacing obsolete "<tt></tt>").
>>>
>>> Thanks,
>>> Alexander
>>
>> Hi Alexander,
>>
>> mostly looks good to me - with afew remarks though.
>>
>> In some files, such as
>> src/java.base/share/classes/java/io/Console.java and
>> src/java.base/share/classes/java/lang/ClassLoader.java
>> (possibly others) - you're using formatting like:
>>
>> +    * <code>{@link #readLine}</code>.
>>
>> The <code></code> is not needed around {@link } - as that should be
>> the default formatting for {@link } (we use {@linkplain } when we
>> don't want the code formatting for @link).
>>
>>
>> src/java.base/share/classes/java/io/File.java
>>
>> +     * <blockquote><code>
>> +     * new File(</code><i> f</i><code>.{@link
>> +     * #toURI() toURI}()).equals(</code><i> f</i><code>.{@link
>> +     * #getAbsoluteFile() getAbsoluteFile}())
>> +     * </code></blockquote>
>>
>> Would that be easier to read as:
>>
>>      * <blockquote>{@code new File(f.}{@link
>>      * #toURI() toURI()}{@code .equals(f.}{@link
>>      * #getAbsoluteFile() getAbsoluteFile()}{@code )}
>>      * </blockquote>
>>
>> (not sure why the original text has hard spaces &nbsp - as
>>  we usually don't put any space after an open parenthesis)
>>
>> Same remark for this a few lines below:
>>
>> +     * <blockquote><code>
>> +     * new {@link #File(java.net.URI) File}(</code><i> f</i>{@code
>> +     * .toURI()).equals(}<i> f</i><code>.{@link 
>> #getAbsoluteFile() getAbsoluteFile}())
>> +     * </code></blockquote>
>>
>> I mean - I don't particularly object but if the goal is to replace
>> <code></code> and <tt></tt> everywhere - then why not go the full
>> way down?
>>
>> The other question is whether <pre></pre> would be a better fit than
>> <blockquote><code></code></blockquote>.
>>
>>
>> Otherwise looks good!
>>
>> -- daniel
>




More information about the core-libs-dev mailing list