[9] RFR: 8180375: Rename <baseName>Provider to <packagename>.spi.<simpleName>Provider

Naoto Sato naoto.sato at oracle.com
Tue May 16 18:14:25 UTC 2017


Please review the changes to the following issue:


The proposed fix is located at:


This is to change the package name of the resource bundle provider to a 
different one, by appending ".spi" to the original package name. This 
change effectively avoids possible split package issue if resource 
bundles are provided from other named modules.


More information about the core-libs-dev mailing list