[RFR] 8205525 : Improve exception messages during manifest parsing of jar archives

Sean Mullan sean.mullan at oracle.com
Mon Sep 10 14:35:18 UTC 2018

On 9/10/18 9:59 AM, Baesken, Matthias wrote:
> New webrev :
> http://cr.openjdk.java.net/~mbaesken/webrevs/8205525.9/
> - SocketExceptions class has been adjusted to new sun.security.util.SecurityProperties
> - Attributes  getErrorPosition   adjusted  (see proposal of Christoph " I think it would be enough to drop the privileged section and just return "filename" as is.)
> After the changes I wonder - should  the  jarPath  category   be  renamed to jarFile  (or something else) ?

Yes, renaming it to "jarFile" makes more sense. You will need to update 
the CSR with this change too.

A few other comments:

- java/util/jar/Manifest.java

   62     // name of the corresponding jar archive if available.
   63     private String jarFilename;

You can mark this final.

- sun/net/util/SocketExceptions.java

   33 import java.security.Security;

This import is no longer needed.


More information about the core-libs-dev mailing list