[RFR] 8205525 : Improve exception messages during manifest parsing of jar archives

Sean Mullan sean.mullan at oracle.com
Tue Sep 11 18:44:07 UTC 2018

On 9/11/18 8:14 AM, Langer, Christoph wrote:
> Hi,
> first of all, I suggest to use "jarDetails" instead of "jarPath" as category name. Because with this contribution we add the notion of jar file plus line of manifest to Exceptions occurring when parsing jar manifests. And if there were further Exception details to be added in the area of jar files, they could go under a category "jarDetails" as well. Would you agree? Then, in Manifest.java, the field "jarPathInExceptionText" could be renamed to "detailedExceptions".

Or just "jar" would be my preference. I don't like "jarPath" as that 
sounds too much like a file pathname to me, which we have now removed.


More information about the core-libs-dev mailing list