[RFC][icedtea-web] Do not allow searching of jar manifest classpath if jnlp_href is being used

Danesh Dadachanji ddadacha at redhat.com
Tue Aug 14 12:15:19 PDT 2012

On 14/08/12 07:44 AM, Jiri Vanek wrote:
> On 07/09/2012 04:51 PM, Danesh Dadachanji wrote:
>> With the many improvements in the test engine, I have been able to write up the tests for this finally! Many thanks to Jiri for all
>> the features added to the test engine!
>> ChangeLog:
>> +2012-07-09 Danesh Dadachanji <ddadacha at redhat.com>
>> +
>> + Classpaths in jars' manifests are only considered when the applet is run
>> + without using jnlp_href and a JNLP file.
>> + * netx/net/sourceforge/jnlp/runtime/JNLPClassLoader.java (activateJars):
>> + Add conditional check for use of jnlp_href.
>> + * tests/reproducers/signed/Classpath.Manifest.Test.Helper/srcs/CheckForClasspath.java:
>> + Applet whose jar is stored in a subdir under the test engine server.
>> + * tests/reproducers/signed/ClasspathManifestTest/resources/ClasspathManifestAppletTest.html:
>> + * tests/reproducers/signed/ClasspathManifestTest/resources/ClasspathManifestAppletTest.jnlp:
>> + * tests/reproducers/signed/ClasspathManifestTest/resources/ClasspathManifestApplicationTest.jnlp:
>> + * tests/reproducers/signed/ClasspathManifestTest/resources/ClasspathManifestJNLPHrefTest.html:
>> + * tests/reproducers/signed/ClasspathManifestTest/srcs/ClasspathManifest.java:
>> + * tests/reproducers/signed/ClasspathManifestTest/srcs/META-INF/MANIFEST.MF:
>> + * tests/reproducers/signed/ClasspathManifestTest/testcases/ClasspathManifestTest.java:
>> + Test if manifest entry is searched for classpath only when in the plugin
>> + is run without using jnlp_href.
>> +
>> I've updated my changeset (first attachment), I had forgotten a '!' in the if-statement there. Is this one okay for HEAD and to
>> backport?
>> The above scenarios that are supposed to fail (applets run by some JNLP file) do not fail in HEAD when run locally. I ran into some
>> issues with running the above tests locally though, the X11 display is not found. I've attached a second patch that will add said
>> tests. It's missing one, the passing browser test.
> I have not noticed those. Everything worked fine on head.

Weird, I tried again on my local machine and it complains but it works on another one. However, this raises another issue. This fix 
only works for remote application launchers, classpath is still searched when you run locally. E.g. file:///some/path/to/test.jnlp will 
search classpath. I've attached my latest patch just for records.

>> Cheers,
>> Danesh
> Hi! Sorry for delay,I'm ok with patch and tests.
> Before push to head and 1.3, please check that everything working on both of them.
> Also please get rid of all the   Assert.assertFalse/true(pr.wasTerminated);   Assert.assertEquals/notEqals((Integer) 0,
> pr.returnValue); They are outdated already.

Done. Thanks for pointing this out!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: no-classpath-with-jnlp_href-HEAD-03.patch
Type: text/x-patch
Size: 23182 bytes
Desc: not available
Url : http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20120814/c603eb92/no-classpath-with-jnlp_href-HEAD-03.patch 

More information about the distro-pkg-dev mailing list