Is --with-openjdk-src-dir working properly?

Magnus Ihse Bursie magnus.ihse.bursie at
Fri Aug 24 08:08:33 PDT 2012

I tried to build IcedTea with my local copy of the build-infra forest, 
using the following configure command line:
./configure --disable-system-lcms --with-openjdk-src-dir=../build-infra-jdk8

However, the build fails when applying patches; I tried removing the 
patches individually (just to see if I could continue compiling, a bit 
quick and dirty) but it seems that *all* patches consistently fails. 
Furthermore, patch gives an error message like:
Checking patches/boot/demos.patch
1 out of 1 hunk FAILED -- saving rejects to file 

However, there is no reject file at the given path. I almost get the 
impression there is some kind of permission problem. However, all 
permissions is correct, and I can edit the files in question without 
problems from an editor.

I noticed that the source is not actually copied, but hard-linked by:
cp -pPR -l ../build-infra-jdk8 openjdk

I'm not very used to working with hard links. Could this be the cause of 
any problem?

Or to state the problem differently, has anyone used 
--with-openjdk-src-dir recently and can confirm that it is working?


More information about the distro-pkg-dev mailing list