[rfc][icedtea-web] intorduce MultipleDeploymentPropertiesModifier
jvanek at redhat.com
Thu Apr 23 16:55:23 UTC 2015
On 04/23/2015 04:45 PM, Jie Kang wrote:
> My objections from the previous threads are still here.
> I would prefer simply modifying DeploymentPropertiesModifier to be able to deal with multiple properties. It's PropertiesModifier, not PropertyModifier after all.
The original name is wrong then. (I considered it correct, because it modifes porperties.deployment file. Tahts why propertiesModifier)
Generally I'm strongly against that adding of new functionality to current impl and standing behind wrapping object. Thats what objects are for! A lot of small (smallest possible to do the current job), well tested objects arealways better then one gigantic objcet doing all.
Thats what decomposition is for. If you dont like it, then java is wrong language and you should look to c/asm ;)
> At the very least, MultipleDeploymentPropertiesModifier should be it's own class with it's own test class.
Although I do not see an reason, for it (actually I see rasons against it) I will do as you wish. Ok to head afterwards?
> As well, please split the tests up similar to how they're split for the DeploymentPropertiesModifier tests. One for setting, one for resetting, etc.
If current approach will be kept, then it is not necessary, because the cases are already covered in PropertiesModifier tests And the wrapping class is using already well tested behaviour. So new test is only for new functionality - multiple changes added by thgis object.
Thats why it is good. I would even say it is simple applciation of Mathematical induction:)
> ----- Original Message -----
>> small class able to gather several DeploymentPropertiesModifiers and
>> apply/revert themin bulk.
More information about the distro-pkg-dev