[Bug 3703] Unable to launch the application with the JNLP file of the app

bugzilla-daemon at icedtea.classpath.org bugzilla-daemon at icedtea.classpath.org
Tue Feb 19 05:43:17 UTC 2019


--- Comment #4 from K. Nagarajan <nagarajan.krishnamurthy at nttdata.com> ---
@JiriVanek - thanks for your suggestion. I ran javaws.bat with -nosecurity
option, but it didn't help. 

Then I ran it with -verbose option and found that there is a problem with SSL
handshake with the remote host and I got the following error for each of the
jar files:

got javax.net.ssl.SSLHandshakeException: Remote host closed connection during

Then, I realized that this tool, since it's built with Java 7, should be using
TLS 1.0 which probably was rejected by the remote host (our app server).

So, as per instructions at the beginning of javaws.bat, I set the environment
variable JAVAWS_J_OPTIONS to -Dhttps.protocols=TLSv1.1,TLSv1.2 and ran it

In the output, I noted that the above Java runtime option was being pass to

But still the remote host closed connection during SSL handshake.

Can you please throw some light on why this is happening? Thanks.

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20190219/67745f06/attachment.html>

More information about the distro-pkg-dev mailing list