RFR: 8154110: Update class* and safepoint* logging subsystems

Max Ockner max.ockner at oracle.com
Thu Apr 28 19:11:13 UTC 2016


Here is an RFE: https://bugs.openjdk.java.net/browse/JDK-8155666.
Basically we want to reevaluate our tag choices and potentially decide 
on a set of conventions to follow for tag names in the future.

I will commit the fix for 8154110 now.
Thanks,
Max
On 4/27/2016 3:52 PM, Max Ockner wrote:
> Unless anyone feels that "constraints" is absolutely unacceptable, I 
> think we should leave it alone. Shall we file a bug so we can relocate 
> this discussion?
>
> Max
>
> On 4/27/2016 3:19 PM, Christian Thalinger wrote:
>>> On Apr 27, 2016, at 2:19 AM, Coleen Phillimore 
>>> <coleen.phillimore at oracle.com> wrote:
>>>
>>>
>>>
>>> On 4/27/16 8:17 AM, David Holmes wrote:
>>>>
>>>> On 27/04/2016 7:41 PM, Marcus Larsson wrote:
>>>>>
>>>>> On 04/27/2016 11:19 AM, David Holmes wrote:
>>>>>> On 27/04/2016 6:39 PM, Marcus Larsson wrote:
>>>>>>> Hi,
>>>>>>>
>>>>>>>
>>>>>>> On 04/27/2016 10:32 AM, Ioi Lam wrote:
>>>>>>>>
>>>>>>>> On 4/26/16 6:13 PM, David Holmes wrote:
>>>>>>>>> On 27/04/2016 10:21 AM, Ioi Lam wrote:
>>>>>>>>>> The changes look good to me.
>>>>>>>>>>
>>>>>>>>>> I think each line of the "constraints" prints only one item (?).
>>>>>>>>>> If so,
>>>>>>>>>> we should use the singular form. (Max, could you post a 
>>>>>>>>>> sample output
>>>>>>>>>> from -Xlog?)
>>>>>>>>> The point is that it shows all the constraints.
>>>>>>>>>
>>>>>>>> We currently have a mix-match of singular/plural forms in the 
>>>>>>>> log tags:
>>>>>>>>
>>>>>>>> singular:
>>>>>>>>   LOG_TAG(alloc)
>>>>>>>>   LOG_TAG(region)
>>>>>>>>
>>>>>>>> plural:
>>>>>>>>   LOG_TAG(defaultmethods)
>>>>>>>>
>>>>>>>> Sometimes whether to use an (s) can be a personal preference. 
>>>>>>>> However,
>>>>>>>> the poor user would need to try 2^n times to get the right 
>>>>>>>> combination
>>>>>>>> of (s) or (no s), and that's too much.
>>>>>>> Yeah, we should definitely be consistent with this. I vote for 
>>>>>>> tags in
>>>>>>> singular, since it makes them ever so slightly shorter.
>>>>>> Hmmm, so data becomes datum? Or is that the exception to the 
>>>>>> rule? ;-)
>>>>> Seems like a good exception to me. :) Perhaps the rule should be to
>>>>> avoid trailing s if it signifies plural.
>>>>>
>>>>>> No matter what you choose some things will be unintuitively awkward:
>>>>>> defaultmethods, exceptions, constraints, all suit plural forms 
>>>>>> and are
>>>>>> awkward in singular. There are numerous plural forms in use already.
>>>>> I don't see what distinguishes the tags you mention from the 
>>>>> others. I
>>>>> guess I don't see what makes them awkward in singular. If I want
>>>>> defaultmethod logging I enable that tag. It's obvious I will get
>>>>> multiple log messages for it so I don't see the purpose of the 's'.
>>>> Maybe it is just familiarity with the old TraceXXX forms. I prefer 
>>>> the noun forms to be plural - as many of them are. Many of the ones 
>>>> that are not are a prefix taken from a longer form ie 
>>>> TraceThreadXXX became thread + xxx; whereas TraceExceptions became 
>>>> exceptions.
>>>>
>>>> It is all somewhat arbitrary in my view.
>>> LOL, we said the same thing.
>> I’d like to propose another approach:  constraintz
>>
>> It’s way cooler and rulezzzz!
>>
>>> Coleen
>>>
>>>> David
>>>>
>>>>> Thanks,
>>>>> Marcus
>>>>>
>>>>>> David
>>>>>>
>>>>>>> Thanks,
>>>>>>> Marcus
>>>>>>>
>>>>>>>> - Ioi
>>>>>>>>
>>>>>>>>> David
>>>>>>>>>
>>>>>>>>>> Thanks
>>>>>>>>>> - Ioi
>>>>>>>>>>
>>>>>>>>>> On 4/26/16 2:05 PM, Max Ockner wrote:
>>>>>>>>>>> New webrev: 
>>>>>>>>>>> http://cr.openjdk.java.net/~mockner/8154110.hotspot.02/
>>>>>>>>>>>
>>>>>>>>>>> I have responded to these suggestions:
>>>>>>>>>>> - class+loaderdata -> class+loader+data
>>>>>>>>>>> - class+loaderconstraints -> class+loader+constraints
>>>>>>>>>>> - I did not change constraints to constraint. I agree with 
>>>>>>>>>>> Coleen's
>>>>>>>>>>> reasoning, but please let me know if you think there is a good
>>>>>>>>>>> reason
>>>>>>>>>>> to change it.
>>>>>>>>>>>
>>>>>>>>>>> Thanks,
>>>>>>>>>>> Max
>>>>>>>>>>>
>>>>>>>>>>> On 4/26/2016 4:05 PM, Coleen Phillimore wrote:
>>>>>>>>>>>> Hi,
>>>>>>>>>>>>
>>>>>>>>>>>> Yes, his looks good, but I agree that class, 
>>>>>>>>>>>> loaderconstraints =>
>>>>>>>>>>>> class, loader, constraints
>>>>>>>>>>>> and class, loaderdata => class, loader, data
>>>>>>>>>>>>
>>>>>>>>>>>> But I think constraints should be plural, we're logging the
>>>>>>>>>>>> constraint checking (more than one constraint) so plural 
>>>>>>>>>>>> makes more
>>>>>>>>>>>> sense to me.
>>>>>>>>>>>>
>>>>>>>>>>>> Okay, I think I now prefer the combination of short words 
>>>>>>>>>>>> to do
>>>>>>>>>>>> logging after seeing this change.
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks,
>>>>>>>>>>>> Coleen
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On 4/26/16 3:44 PM, Robbin Ehn wrote:
>>>>>>>>>>>>> Hi Max,
>>>>>>>>>>>>>
>>>>>>>>>>>>> I was just looking at these tags and thought maybe they 
>>>>>>>>>>>>> should be
>>>>>>>>>>>>> split, nice !
>>>>>>>>>>>>>
>>>>>>>>>>>>> I have request for the ' constraints' tag, can make it 
>>>>>>>>>>>>> singular
>>>>>>>>>>>>> (without ending 's') ?
>>>>>>>>>>>>>
>>>>>>>>>>>>> (there are a few other ones in plural which we also should 
>>>>>>>>>>>>> fix)
>>>>>>>>>>>>>
>>>>>>>>>>>>> Otherwise I think this looks good!
>>>>>>>>>>>>>
>>>>>>>>>>>>> Thanks!
>>>>>>>>>>>>>
>>>>>>>>>>>>> /Robbin
>>>>>>>>>>>>>
>>>>>>>>>>>>> On 04/26/2016 07:42 AM, Max Ockner wrote:
>>>>>>>>>>>>>> Hello,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> This change factors the tags from the class and safepoint 
>>>>>>>>>>>>>> logging
>>>>>>>>>>>>>> subsystems into smaller tags, including "class" and 
>>>>>>>>>>>>>> "safepoint"
>>>>>>>>>>>>>> tags which are included in tag combination in their 
>>>>>>>>>>>>>> respective
>>>>>>>>>>>>>> subsystems.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> classresolve -> class+resolve
>>>>>>>>>>>>>> classload -> class+load
>>>>>>>>>>>>>> classunload -> class+unload
>>>>>>>>>>>>>> classpath -> class+path
>>>>>>>>>>>>>> classloaderdata -> class+loaderdata
>>>>>>>>>>>>>> classload+constraints -> class+loaderconstraints
>>>>>>>>>>>>>> classinit -> class+init
>>>>>>>>>>>>>> classload+preorder -> class+preorder
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> safepointcleanup -> safepoint+cleanup
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> class+loaderdata can be further factored into 
>>>>>>>>>>>>>> class+load+data.
>>>>>>>>>>>>>> Same
>>>>>>>>>>>>>> with class+loaderconstraints.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Bug: https://bugs.openjdk.java.net/browse/JDK-8154110
>>>>>>>>>>>>>> webrev(hotspot):
>>>>>>>>>>>>>> http://cr.openjdk.java.net/~mockner/8154110.hotspot/
>>>>>>>>>>>>>> webrev(jdk): 
>>>>>>>>>>>>>> http://cr.openjdk.java.net/~mockner/8154110.jdk/
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Tested with jtreg hotspot tests. jdk tests currently 
>>>>>>>>>>>>>> running.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>>> Max
>



More information about the hotspot-dev mailing list