RFR: JDK-8257588: Make os::_page_sizes a bitmask [v3]

Thomas Stuefe stuefe at openjdk.java.net
Fri Dec 4 05:35:03 UTC 2020


On Thu, 3 Dec 2020 22:56:04 GMT, Marcus G K Williams <github.com+168222+mgkwill at openjdk.org> wrote:

>> src/hotspot/share/runtime/os.hpp line 110:
>> 
>>> 108:     PagesizeSet() : _v(0) {}
>>> 109:     void add(size_t pagesize);
>>> 110:     bool is_set(size_t pagesize) const;
>> 
>> Could this be private. It's an implementation detail that you use a bit set and have "set" bits. If not, maybe consider a more high-level name. is_added, is_registered, contains?
>
> I'd prefer if this stays public, I've already found it useful, but I agree that the name could be more informative. Perhaps contains(size_t pagesize)?

Cannot be private since its used from other nested classes (os::Linux etc). But I can rename it to contains()

-------------

PR: https://git.openjdk.java.net/jdk/pull/1522


More information about the hotspot-dev mailing list