Request for review: 8010506 Typos and errors in gc-related flags in globals.hpp

Tao Mao tao.mao at oracle.com
Tue Apr 30 23:58:57 UTC 2013


new webrev
http://cr.openjdk.java.net/~tamao/8010506/webrev.01/

It needs reviews.

Changeset:
Thank you for the thorough report of all these typos/errros, Thomas.

I changed most places according to your suggestions (for the rest few, I 
did not change because it may slightly change the meaning of the 
definition). Also, I went through the file to change some similar common 
errors that occurred.

Several issues:

(1) parallel gc should be lower case or upper case?
As I know and, perhaps, someone told me, the term "parallel gc" 
sometimes refers to a more generic terminology rather than ParallelGC or 
ParallelOldGC, if it doesn't imply these two. Basically, any GC 
algorithms that can be parallelized could fall into this category. Right 
now, we probably refer "parallel gc" to ParallelGC or ParallelOldGC. 
But, we reserve the right to change it to something else. That's why 
"fuzziness" exists here. I guess the same way to deal with "concurrent 
gc". So, I didn't make these words upper cased.

(2) Identification:
The general rule is to follow the example (product()'s identification). 
The whole file checked and space adjusted accordingly.

(3) Line breaks
A space should be provided at the line breaks if multiple lines is 
needed. Some lines that are slightly longer than normal length is kept 
untouched as long as they read well.

*(4) Why does the VM option hashCode have lower case initial?
The direct answer is "I don't know". (But it is understandable that 
hashCode is "legacy" such that it has it own style) Anyone knows the answer?

Thanks.
Tao

On 3/21/13 3:09 PM, Tao Mao wrote:
> 8010506 Typos and errors in gc-related flags in globals.hpp
> https://jbs.oracle.com/bugs/browse/JDK-8010506
>
> webrev:
> http://cr.openjdk.java.net/~tamao/8010506/webrev.00/
>
> Changeset:
> NewRatio should defined as
> product(uintx, NewRatio, 
> 2,                                               \
>     "Ratio of old/new generation sizes")                              \
> instead of
> product(uintx, NewRatio, 
> 2,                                               \
>     "Ratio of new/old generation sizes")                              \
>
> PLUS other typos found by Jesper.



More information about the hotspot-gc-dev mailing list