RFR(S): JDK-8042474: Clean up duplicated code in RSHashTable

Andreas Sjöberg andreas.sjoberg at oracle.com
Thu May 8 08:01:20 UTC 2014


Hi all,

could I please have reviews for this small cleanup?
For RSHashTable, it
  - removes entry_for_region_ind(RegionIdx_t)
  - changes get_entry to be public and declared const
  - changes the sites that called entry_for_region to instead use 
get_entry, since they have the same implementation.
  - changes get_cards to make use of get_entry instead of very similar 
code contained inline.

webrev: http://cr.openjdk.java.net/~brutisso/JDK-8042474/01/webrev/

It seems get_cards is not used. Maybe it should be removed as a separate CR?

testing: jprt.

Best regards,
Andreas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/hotspot-gc-dev/attachments/20140508/c8403b3f/attachment.htm>


More information about the hotspot-gc-dev mailing list