RFR: JDK-8151605: Change warning() to log_warning(gc) in the GC code

Jesper Wilhelmsson jesper.wilhelmsson at oracle.com
Thu Mar 10 13:35:24 UTC 2016


Looks good in general. A few minor nits (just vaguely related to your change):

* gc/cms/concurrentMarkSweepGeneration.cpp The comment say it prints a warning, 
but we print a debug message. Not sure if we care.
5777 // We print a warning message only once per CMS cycle.
5778 log_debug(gc)(" (benign) Hit CMSMarkStack max size limit");

* gc/parallel/gcTaskThread.cpp you changed the indentation to four spaces. The 
line below (unchanged) is also badly indented and could be fixed.

* gc/parallel/psOldGen.cpp the if around the logging could use { }

* gc/parallel/psParallelCompact.cpp you changed the number of spaces in the 
first two log messages. I'm not sure if anyone is parsing this logging and I 
would argue that your change makes it better. Just wanted to point out that the 
actual message is changed here to make sure it was done on purpose.

* gc/shared/cardGeneration.cpp the if around the logging could use { }

Fix it if you feel like it :)  No new webrev is called for.

Thanks,
/Jesper


Den 10/3/16 kl. 11:00, skrev Bengt Rutisson:
>
> Hi everyone,
>
> Could I have a couple of reviews for this change?
>
> https://bugs.openjdk.java.net/browse/JDK-8151605
> http://cr.openjdk.java.net/~brutisso/8151605/webrev.00/
>
> With the new logging framework we should use log_warning() instead of warning().
>
> Thanks,
> Bengt



More information about the hotspot-gc-dev mailing list