RFR: 8177544: Restructure G1 Full GC code

Stefan Johansson stefan.johansson at oracle.com
Thu Jun 8 12:35:58 UTC 2017


Hi,

Please review this enhancement:
https://bugs.openjdk.java.net/browse/JDK-8177544

Webrev:
http://cr.openjdk.java.net/~sjohanss/8177544/hotspot.00/

Summary:
This is more or less only code moving around. The function 
do_full_collection in G1CollectedHeap is very large and breaking it up 
to smaller parts and grouping together some of the stack objects help 
readability.

In addition to splitting the large function to smaller ones I've 
introduced two new classes:
- G1FullGCScope that groups most of the previously spread out stack objects.
- G1SerialCollector that handles the interaction with G1MarkSweep.

Doing this change will simplify future changes to the full GC.

Testing:
* Locally run JTREG tests
* RBT hotspot tier 2 & 3

Thanks,
Stefan



More information about the hotspot-gc-dev mailing list