RFR(T): 8230192: Rename G1RedirtyCardsBufferList to G1BufferNodeList

Leo Korinth leo.korinth at oracle.com
Tue Aug 27 09:43:58 UTC 2019

On 27/08/2019 01:05, Kim Barrett wrote:
> Please review this trivial refactoring that renames a simple utility
> struct and moves its definition to its own .hpp/.cpp files.  This will
> permit the class to be used in other contexts that aren't related to
> redirtying cards.  (I have a change in development that does just
> that, and broke this piece out.)
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8230192
> Webrev:
> http://cr.openjdk.java.net/~kbarrett/8230192/open.00/
> Testing:
> Local (linux-x64) hotspot:tier1.

Looks good to me.


More information about the hotspot-gc-dev mailing list