RFR (S): 8238220: Rename OWSTTaskTerminator to TaskTerminator

sangheon.kim at oracle.com sangheon.kim at oracle.com
Thu Jan 30 18:08:48 UTC 2020

Hi Thomas,

On 1/30/20 3:34 AM, Thomas Schatzl wrote:
> Hi all,
>   can I have reviews for this renaming change of OWSTTaskTerminator to 
> TaskTerminator now that there is only one task termination protocol 
> implementation?
> I believe that the OWST prefix only makes the code harder to read 
> without conveying interesting information at the uses.
> Based on JDK-8215297.
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8238220
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/8238220/webrev/
Looks good as is.

One thing to note is the order of renamed header file.
It looks like you are treating uppercase first? :)

e.g. at g1CollectedHeap.cpp

+#include "gc/shared/taskTerminator.hpp"
  #include "gc/shared/taskqueue.inline.hpp"

I expect alphabet order first and then upper-lowercase. :)


> Testing:
> local compilation
> Thanks,
>   Thomas

More information about the hotspot-gc-dev mailing list