RFR: 8278351: Add function to retrieve worker_id from any context [v2]

Per Liden pliden at openjdk.java.net
Mon Dec 13 11:06:49 UTC 2021


On Thu, 9 Dec 2021 17:58:57 GMT, Per Liden <pliden at openjdk.org> wrote:

>> The `worker_id` argument passed to `WorkerTask::work(uint worker_id)` is sometimes needed in contexts where it today can't be easily accessed, mainly because it's not feasible to pass this argument through many layers of semi-unrelated code. To solve this, I propose that we make the current `worker_id` accessible though a static function `WorkerThread::worker_id()`.
>> 
>> By doing this, we also pave the way for ZGC to remove its `ZTask` and `ZThread`, which are helper class to make the `worker_id` easily accessible in any context.
>> 
>> At the same time I propose that we remove `WorkerThread::_id`. This id identifies the actual worker thread. There is currently only one user of `WorkerThread::_id`, the `ReferenceProcessor`. However, we should use `WorkerThread::worker_id()` here instead. The only reason it doesn't use `worker_id` today is that it's not easily accessible in that context (the discover path).
>> 
>> Testing: Passed Tier1-3
>
> Per Liden has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains three additional commits since the last revision:
> 
>  - Merge branch 'master' into 8278351_worker_id
>  - Adjustments
>  - 8278351: Make WorkerThread::id() map to worker_id

Updated after comments from @albertnetymk, who through `which` wasn't a good name. Renamed it to `name_suffix` and added a separate `on_create_worker()` hook to avoid exposing that number outside of the `WorkerThreads`.

-------------

PR: https://git.openjdk.java.net/jdk/pull/6747



More information about the hotspot-gc-dev mailing list