RFR: 8067306: Improve STATIC_ASSERT

Coleen Phillimore coleen.phillimore at oracle.com
Fri Jan 9 13:45:30 UTC 2015

This looks like a good change.   I didn't realize we had 
STATIC_ASSERT.   Is there any supporting opinion to make it lower case 
so it doesn't scream at you in the code?


On 1/9/15, 4:00 AM, Erik Helin wrote:
> On 2015-01-08, Kim Barrett wrote:
>> On Jan 7, 2015, at 7:25 AM, Stefan Karlsson <stefan.karlsson at oracle.com> wrote:
>>> I'll sponsor and review the patch if you change "(Cond) ? true : false" to just "(Cond)". Any potential problems with ancient compilers can be dealt with when / if they are causing problems.
>> CR: https://bugs.openjdk.java.net/browse/JDK-8067306
>> New full webrev: http://cr.openjdk.java.net/~kbarrett/8067306/webrev.03/
>> Incremental webrev: http://cr.openjdk.java.net/~kbarrett/8067306/webrev.03.incr/
> Still good, Reviewed.
> Thanks,
> Erik

More information about the hotspot-runtime-dev mailing list