RFR (XS): 8067728: Flag::unlock_diagnostic() should be called Flag::clear_diagnostic()

Rachel Protacio rachel.protacio at oracle.com
Tue May 2 18:52:17 UTC 2017


Sure thing. http://cr.openjdk.java.net/~rprotacio/8067728.01

Rachel

On 5/2/2017 2:19 PM, Ioi Lam wrote:
> Hi Rachel,
>
> Looks good, but while you're doing this, maybe add:
>
>  417 void Flag::clear_diagnostic() {
>  418   assert(is_diagnostic(), "sanity");
>  419   _flags = Flags(_flags & ~KIND_DIAGNOSTIC);
>        assert(!is_diagnostic(), "sanity");
>  420 }
>
> Thanks
> - Ioi
>
> On 5/2/17 11:15 AM, Rachel Protacio wrote:
>> Hi,
>>
>> Please review this tiny change, renaming Flag::unlock_diagnostic() as 
>> Flag::clear_diagnostic.
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8067728
>> Open webrev: http://cr.openjdk.java.net/~rprotacio/8067728.00/
>>
>> Thanks!
>> Rachel
>



More information about the hotspot-runtime-dev mailing list