RFR(XXS) 8199741: NMT: Tag safepoint polling pages

coleen.phillimore at oracle.com coleen.phillimore at oracle.com
Fri Mar 16 15:50:12 UTC 2018


Yay, a quick code review.  Is there a better mt tag than mtInternal 
though?  There are too many mtInternal allocations.  Can you add 
mtSafepoint or mtSynchronize (or better name?) and we could have an RFE 
to make some of these into the same:

share/runtime/semaphore.hpp:class Semaphore : public CHeapObj<mtInternal> {
share/runtime/mutex.hpp:class Monitor : public CHeapObj<mtInternal> {
share/runtime/objectMonitor.cpp:  return AllocateHeap(size, mtInternal);
share/runtime/objectMonitor.cpp:  char * knobs = (char *) os::malloc(sz 
+ 2, mtInternal);
share/runtime/monitorChunk.cpp:  _monitors           = 
NEW_C_HEAP_ARRAY(BasicObjectLock, number_on_monitors, mtInternal);

Or even mtOS so we can move some of the os allocations to this category?

Why is nothing simple?! :)

Coleen

On 3/16/18 11:34 AM, Zhengyu Gu wrote:
> A trivial fix to add NMT tag to Safepoint poll pages.
>
> Bug: https://bugs.openjdk.java.net/browse/JDK-8199741
> Webrev: http://cr.openjdk.java.net/~zgu/8199741/webrev.00/
>
> Test:
>   Eyeball NMT output on Linux x64.
>
> Thanks,
>
> -Zhengyu



More information about the hotspot-runtime-dev mailing list