RFR: 8263632: Improve exception handling of APIs in classLoader.cpp [v2]

Calvin Cheung ccheung at openjdk.java.net
Fri Mar 26 16:11:45 UTC 2021


> Please review this change which includes:
> 
> -  adding `ClassLoader::create_class_path_entry_or_fail()` and `ClassLoader::create_class_path_entry_or_fail()` functions for better readability. They will call the existing `ClassLoader::create_class_path_entry()`.
> - replacing the TRAPS parameter with `Thread* current` for the functions which never throw exception.
> 
> Testing: tiers 1,2 (passed); tiers 3,4 (in progress).

Calvin Cheung has updated the pull request incrementally with one additional commit since the last revision:

  get rid of throw_exception in ClassLoader::create_class_path_entry

-------------

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/3203/files
  - new: https://git.openjdk.java.net/jdk/pull/3203/files/52632b62..c2d1cde7

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=3203&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=3203&range=00-01

  Stats: 132 lines in 6 files changed: 9 ins; 52 del; 71 mod
  Patch: https://git.openjdk.java.net/jdk/pull/3203.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/3203/head:pull/3203

PR: https://git.openjdk.java.net/jdk/pull/3203


More information about the hotspot-runtime-dev mailing list