RFR: 8263632: Improve exception handling of APIs in classLoader.cpp [v3]

Ioi Lam iklam at openjdk.java.net
Fri Mar 26 17:18:30 UTC 2021


On Fri, 26 Mar 2021 16:47:39 GMT, Calvin Cheung <ccheung at openjdk.org> wrote:

>> Please review this change which includes:
>> 
>> -  adding `ClassLoader::create_class_path_entry_or_fail()` and `ClassLoader::create_class_path_entry_or_fail()` functions for better readability. They will call the existing `ClassLoader::create_class_path_entry()`.
>> - replacing the TRAPS parameter with `Thread* current` for the functions which never throw exception.
>> 
>> Testing: tiers 1,2 (passed); tiers 3,4 (in progress).
>
> Calvin Cheung has updated the pull request incrementally with one additional commit since the last revision:
> 
>   @coleenp review comment

LGTM. Just one small nit.

src/hotspot/share/classfile/classLoader.cpp line 559:

> 557:     add_to_module_path_entries(path, new_entry);
> 558:   }
> 559:   return;

nit: return is no longer needed.

-------------

Marked as reviewed by iklam (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/3203


More information about the hotspot-runtime-dev mailing list