Integrated: 8267191: Avoid repeated SystemDictionaryShared::should_be_excluded calls

Ioi Lam iklam at openjdk.java.net
Wed May 19 19:34:48 UTC 2021


On Mon, 17 May 2021 17:39:32 GMT, Ioi Lam <iklam at openjdk.org> wrote:

> `SystemDictionaryShared::should_be_excluded` is called during CDS dump time to see if a class should be excluded from the archive. This function calls itself to check super types. As a result, some classes many be checked more than once.
> 
> The repeated calls slows down dumping. Also, If a class is excluded, we will see multiple warning messages like this, which is too verbose and confusing.
> 
> 
> Skipping org/eclipse/osgi/util/NLS: Signed JAR
> Skipping org/eclipse/osgi/util/NLS: Signed JAR
> Skipping org/eclipse/osgi/util/NLS: Signed JAR
> 
> 
> BTW, to make the code a little easier to read, I also changed
> 
> 
>  warn_excluded(k, "Failed verification");
>  return true;
> 
> 
> to
> 
> 
> return  warn_excluded(k, "Failed verification");

This pull request has now been integrated.

Changeset: b961f253
Author:    Ioi Lam <iklam at openjdk.org>
URL:       https://git.openjdk.java.net/jdk/commit/b961f2535c9508d6f8e580b8bf53538d6f72b27c
Stats:     77 lines in 2 files changed: 28 ins; 22 del; 27 mod

8267191: Avoid repeated SystemDictionaryShared::should_be_excluded calls

Reviewed-by: dholmes, coleenp

-------------

PR: https://git.openjdk.java.net/jdk/pull/4070


More information about the hotspot-runtime-dev mailing list