OpenJDK 8 Segfault on Startup

Aleksey Shipilev ashipile at
Mon Nov 26 19:47:37 UTC 2018

On 11/26/18 3:22 PM, Attie Grande wrote:
> I'm confident that I've cleared the call to Arguments::parse() in
> Threads::create_vm() [2], but this is getting messy, and surely cannot
> be the correct way to debug JVM.

Yes, {fast,slow}debug build and attached debugger is the correct way to debug JVM. Are you doing GDB
with release build, per chance?

> I've attached an error report: hs_err_pid5803.log.

Attachment was stripped, please put the file somewhere, and post the link?

> - How would I go about debugging OpenJDK to figure out what's going on here?
> - I have a series of patches applies (see below), are there any
> obvious missing or harmful patches?
> - Has anyone been down this road before?

I remember seeing the similar report at #openjdk @ OFTC, was that you? OpenJDK 8 on ARM probably
means Zero VM, and maybe there is Yocto-specific problem, maybe even caused by some Yocto patch. It
is impossible to tell having only the names for the patches :)

Can you try with fastdebug and/or without Yocto patches?

Relevant part of IRC log:

(10:43:57 AM) hitendra [~oftc-webi at] entered the room.
(10:44:44 AM) hitendra: I tried to build latest openjdk-8 (V 162b12) . It successfully compiled for
armv7 processor, But when I run java on imx6 module (Toradex) , it give me core dump Error.
(10:45:01 AM) hitendra: can anyone please help??
(10:50:27 AM) shade: that probably means you built Zero VM?
(10:51:22 AM) shade: anyway, coredumps can be opened with gdb, and "thread apply all bt" would show
where the threads were during that crash
(10:51:50 AM) shade: it is highly advisable to build fastdebug version to look for asserts;
configure --with-debug-level=fastdebug
(10:52:39 AM) hitendra: # A fatal error has been detected by the Java Runtime Environment: # #
Internal Error (os_linux_zero.cpp:254), pid=13475, tid=0x7681e460 #  fatal error: caught unhandled
signal 11 # # JRE version:  (8.0_162-b12) (build ) # Java VM: OpenJDK Zero VM (25.162-b12
interpreted mode linux-arm ) # Core dump written. Default location: /home/root/core or core.13475 #
# An error report file with more information is saved as: # /home/root/hs_err_pid13475.log # #
(10:52:55 AM) hitendra: I got this kind of error
(10:55:16 AM) jerboaa: ok, this is Zero: "OpenJDK Zero VM"
(10:55:57 AM) jerboaa: I'd try running it through a debugger
(10:55:58 AM) hitendra: what is the solution ?
(10:56:21 AM) jerboaa: I don't know. too little info :)
(10:57:45 AM) hitendra: which information You want?
(10:57:57 AM) jerboaa: why 162b12? Have you tried the latest tree from:
(10:59:00 AM) hitendra: is there any know issue with this java version on arm processor??
(10:59:49 AM) jerboaa: hitendra, I don't know we build Zero on Fedora armv7 and haven't had any
major issues
(11:00:46 AM) jerboaa: look for
armv7hl architecture
(11:01:30 AM) shade: unhandled signal? is this running in qemu guest, perchance?
(11:10:10 AM) hitendra: actually i created linux os with yocto  latest (sumo), and clone letest
meta-java banch and truing to build openjdk-8 . it compiled successfully
(11:11:06 AM) hitendra: when i run the java on hardware (imx6 module (Toradex)) it casue core dump error
(11:11:54 AM) jerboaa: so you should probably talk to yocto people about this.


More information about the jdk-dev mailing list