Running micro benchmark results in 'Error: Unable to access jarfile'

Jorn Vernee jbvernee at
Mon Feb 18 21:34:19 UTC 2019

Hi Claes,

> 1. Does running make test rather than make test-only work?

No. Same error there. Sorry, I tried that first and then re-ran with 
`test-only`. I also tried with a clean build FWIW.

> 2. Can you run the benchmarks.jar directly?

Yes, this is working, thanks. This way I can also pass extra flags to 
JMH, which is nice :)


FWIW, I also had some problems when running configure.

   1.) I did not get a warning when I was missing --with-jmh for 
configure, although it looks like there is supposed to be one (without 
--with-jmh I got the same access error, but the benchmarks.jar did not 
   2.) My path to the --with-jmh folder had spaces in it, which was 
causing an error in make/autoconf/lib-tests.m4 on line 76 [1].

But those both had obvious workarounds.


I was hoping to use the framework for Panama, so I'd likely have some 
native library as dependency of the benchmark. Is there currently any 
support for building (native) dependencies automatically?


[1] :

More information about the jdk-dev mailing list