jrt file system now has /package and /modules directories

Michael Hall mik3hall at gmail.com
Mon Nov 16 09:42:32 UTC 2015

> On Nov 16, 2015, at 1:42 AM, Alan Bateman <Alan.Bateman at oracle.com> wrote:

> To your original question then the jrt file system provider in the jigsaw/jake forest has support for exploded builds, the version in the main line JDK 9 forest does not have this support (yet). From the above output then it looks like you have a clone of the JDK 9 main line, maybe jdk9/jdk9 or jdk9/dev, so that explains that part.
> As regards the make target then the README-builds suggests "make all" so that everything is built. When you run just "make" without any make target then it defaults to developer/exploded builds, this is what most people working on the JDK use. I'm not 100% sure why the "install" target doesn't build and install the images, Erik or someone in the build area can probably say more on this.

The install failed because of the missing images. Up to Eric I guess if that is a bug. Yes, I am using a mainline jdk 9 forest. I wouldn’t know how to get a jigsaw specific one.
I did end up doing the install and it worked fine with images there. I shouldn’t of installed. I’m still trying to use Java 8 as the default on my machine and only use 9 embedded runtime from a test app. Now I’ll probably have to reinstall 8 over the top to get it back to default.
A default build that doesn’t create a jvm fully usable from an application doesn’t make a lot of sense to me but I’ll believe you that it does for a majority of people.
Thanks for referring me to the README that I should of looked at, my own page documenting what I did last time on this did say to do ‘make all’ and I didn’t even read that. But I did update it for what thats worth. Maybe I’ll read it next time. 

A couple of other things…
‘make clean’ I remembered had to be sudo’d for me? Doesn’t seem like what I’ve usually done. 

After not succeeding with this I tried to just grab a early access I could work with. Any time I tried to download instead of downloading it took me to a Oracle developer community page. Kenai, Oracle didn’t seem to matter, I couldn’t get a download, everything hauled me off to the community page?

Why are there still separate jre and jdk images? I thought these were going to end up sort of merged depending on modules? Or is the main line build process not really supporting the module part of this at this time? This one I’m assuming is one of those will change over time as the branches merge?

Michael Hall

> On 16/11/2015 00:44, Michael Hall wrote:
>> Not a bad long shot. Seemed to work fine.
>> Creating jre jimage
>> Creating jdk jimage
>> duplicate resource "META-INF/services/com.sun.jdi.connect.Connector", skipping
>> Access verification succeeded.
>> ## Finished verify-modules (build time 00:03:40)
>> Finished building target 'images' in configuration 'macosx-x86_64-normal-server-release’
>> Running this…
>> ~/jdk9/build/macosx-x86_64-normal-server-release/images/jdk/bin/java JRTLister
>> /packages
>> /modules
>> also works now.
>> I am sure it will likewise work from the app.
> -Alan

More information about the jigsaw-dev mailing list