FlatMapper

Raab, Donald Donald.Raab at gs.com
Tue Feb 12 10:52:54 PST 2013


Are we going to have a consistency issue with FlatMapper vs. Function?  For instance we have ToIntFunction, but not ToIntFlatMapper.  Instead we have FlatMapper.ToInt.

> -----Original Message-----
> From: lambda-libs-spec-experts-bounces at openjdk.java.net [mailto:lambda-
> libs-spec-experts-bounces at openjdk.java.net] On Behalf Of Brian Goetz
> Sent: Tuesday, February 12, 2013 1:42 PM
> To: lambda-libs-spec-experts at openjdk.java.net
> Subject: FlatMapper
> 
> Here's where things have currently landed with FlatMapper -- this is a type
> in java.util.stream, with nested specializations.
> 
> Full bikeshed season is now open.  Are we OK with the name explodeInto()?
> Is this general enough to join the ranks of Function and Supplier as top-
> level types in java.util.function?
> 
> @FunctionalInterface
> public interface FlatMapper<T, U> {
>      void explodeInto(T element, Consumer<U> sink);
> 
>      @FunctionalInterface
>      interface ToInt<T> {
>          void explodeInto(T element, IntConsumer sink);
>      }
> 
>      @FunctionalInterface
>      interface ToLong<T> {
>          void explodeInto(T element, LongConsumer sink);
>      }
> 
>      @FunctionalInterface
>      interface ToDouble<T> {
>          void explodeInto(T element, DoubleConsumer sink);
>      }
> 
>      @FunctionalInterface
>      interface OfIntToInt {
>          void explodeInto(int element, IntConsumer sink);
>      }
> 
>      @FunctionalInterface
>      interface OfLongToLong {
>          void explodeInto(long element, LongConsumer sink);
>      }
> 
>      @FunctionalInterface
>      interface OfDoubleToDouble {
>          void explodeInto(double element, DoubleConsumer sink);
>      }
> }


More information about the lambda-libs-spec-experts mailing list