Collector / Collectors

Sam Pullara spullara at gmail.com
Thu Jun 20 10:04:18 PDT 2013


Like it.

Sam

On Jun 20, 2013, at 9:45 AM, Brian Goetz <brian.goetz at oracle.com> wrote:

> Several people have suggested adding:
> 
>  Collector.of(supplier, accumulator, combiner)
>  Collector.of(supplier, accumulator, combiner, finisher)
> 
> which is sensible and easy.
> 
> On 6/18/2013 11:58 AM, Brian Goetz wrote:
>> I think I may (finally!) have a final API candidate for Collector /
>> Collectors.  Updated docs here:
>> 
>>   http://cr.openjdk.java.net/~briangoetz/doctmp/doc/
>> 
>> Salient recent changes:
>>  - Incorporation of finishing function into Collector
>>  - Renamings in Collector API
>>  - Morph toStringBuilder, toStringJoiner into joining()
>>  - Add prefix/suffix version of joining()
>>  - Addition of summingBy{Int,Long,Double}
>>  - Addition of averagingBy{Int,Long,Double}
>>  - Rename toXxxSummaryStatistics to summarizingXxx
>>  - no-see reducing, and minBy/maxBy collectors return Optional
>>  - elimination of canned merger functions from API
>> 
>> Please review the API and spec.  I have set up a SurveyMonkey with the
>> usual password to collect review comments at:
>> 
>>   https://www.surveymonkey.com/s/3TTBJ7K
>> 
>> 



More information about the lambda-libs-spec-experts mailing list