RFR: First refactoring (thaw_fast) [v4]

Coleen Phillimore coleenp at openjdk.java.net
Mon Apr 25 17:38:55 UTC 2022


On Fri, 22 Apr 2022 17:21:38 GMT, Frederic Parain <fparain at openjdk.org> wrote:

>> Refactoring method thaw_fast() for better encapsulation and readability.
>
> Frederic Parain has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains five additional commits since the last revision:
> 
>  - Merge remote-tracking branch 'upstream/fibers' into renaming1
>  - Merge remote-tracking branch 'upstream/fibers' into renaming1
>  - Move new methods to ThawBase
>  - Fixes to address Coleen's comments.
>  - First refactoring (thaw_fast)

Looks good.

src/hotspot/share/runtime/continuationFreezeThaw.cpp line 1763:

> 1761:   // returns the size required to store the frame on stack, and because it is a
> 1762:   // compiled frame, it must include a copy of the arguments passed by the caller
> 1763:   return frame_size + argsize;

small nit, can you put these functions above the ones that call them in the file?

-------------

Marked as reviewed by coleenp (Committer).

PR: https://git.openjdk.java.net/loom/pull/158


More information about the loom-dev mailing list